kernel: update 4.9 to 4.9.51
[openwrt/openwrt.git] / include / image-commands.mk
index 49e438954a804f487652603d7e6682716b533c2b..acf25d64da83d4f1d3577474b717978a7c95cc09 100644 (file)
@@ -8,7 +8,7 @@ define Build/uImage
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
-       @mv $@.new $@
+       mv $@.new $@
 endef
 
 define Build/buffalo-enc
@@ -44,12 +44,17 @@ define Build/buffalo-dhp-image
        mv $@.new $@
 endef
 
+define Build/eva-image
+       $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
+       mv $@.new $@
+endef
+
 define Build/netgear-chk
        $(STAGING_DIR_HOST)/bin/mkchkimg \
                -o $@.new \
                -k $@ \
                -b $(NETGEAR_BOARD_ID) \
-               -r $(NETGEAR_REGION)
+               $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
        mv $@.new $@
 endef
 
@@ -62,6 +67,16 @@ define Build/netgear-dni
        mv $@.new $@
 endef
 
+define Build/append-squashfs-fakeroot-be
+       rm -rf $@.fakefs $@.fakesquashfs
+       mkdir $@.fakefs
+       $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+               $@.fakefs $@.fakesquashfs \
+               -noappend -root-owned -be -nopad -b 65536 \
+               $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+       cat $@.fakesquashfs >> $@
+endef
+
 # append a fake/empty rootfs uImage header, to fool the bootloaders
 # rootfs integrity check
 define Build/append-uImage-fakeroot-hdr
@@ -76,7 +91,7 @@ endef
 
 define Build/tplink-safeloader
        -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
-               -B $(TPLINK_BOARD_NAME) \
+               -B $(TPLINK_BOARD_ID) \
                -V $(REVISION) \
                -k $(IMAGE_KERNEL) \
                -r $@ \
@@ -99,6 +114,11 @@ define Build/install-dtb
        )
 endef
 
+define Build/install-zImage
+    $(CP) $(KDIR)/zImage \
+      $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE_SANITIZED)-zImage
+endef
+
 define Build/fit
        $(TOPDIR)/scripts/mkits.sh \
                -D $(DEVICE_NAME) -o $@.its -k $@ \
@@ -218,6 +238,29 @@ define Build/sysupgrade-tar
                $@
 endef
 
+define Build/tplink-v1-header
+       $(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
+               -E $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+               -m $(TPLINK_HEADER_VERSION) -N "$(VERSION_DIST)" -V $(REVISION) \
+               -k $@ -o $@.new $(1)
+       @mv $@.new $@
+endef
+
+define Build/tplink-v2-header
+       $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
+               -c -V "ver. 2.0" -B $(TPLINK_BOARD_ID) $(1) -k $@ -o $@.new
+       @mv $@.new $@
+endef
+
+define Build/tplink-v2-image
+       $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
+               -a 0x4 -j -V "ver. 2.0" -B $(TPLINK_BOARD_ID) $(1) \
+               -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new
+       cat $@.new >> $@
+       rm -rf $@.new
+endef
+
 json_quote=$(subst ','\'',$(subst ",\",$(1)))
 #")')
 metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))