ar71xx: image: drop unused mtdlayouts from legacy.mk
[openwrt/openwrt.git] / include / image-commands.mk
index 04fa853fbbd99936c547d5eb0862137cba22809d..c1d89825a3bc383ac9200af2093867ba05f0960c 100644 (file)
@@ -8,7 +8,40 @@ define Build/uImage
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
-       @mv $@.new $@
+       mv $@.new $@
+endef
+
+define Build/buffalo-enc
+       $(eval product=$(word 1,$(1)))
+       $(eval version=$(word 2,$(1)))
+       $(eval args=$(wordlist 3,$(words $(1)),$(1)))
+       $(STAGING_DIR_HOST)/bin/buffalo-enc \
+               -p $(product) -v $(version) $(args) \
+               -i $@ -o $@.new
+       mv $@.new $@
+endef
+
+define Build/buffalo-enc-tag
+       $(call Build/buffalo-enc,'' '' -S 152 $(1))
+endef
+
+define Build/buffalo-tag-dhp
+       $(eval product=$(word 1,$(1)))
+       $(eval region=$(word 2,$(1)))
+       $(eval language=$(word 3,$(1)))
+       $(STAGING_DIR_HOST)/bin/buffalo-tag \
+               -d 0x01000000 -w 1 \
+               -a $(BUFFALO_TAG_PLATFORM) \
+               -v $(BUFFALO_TAG_VERSION) -m $(BUFFALO_TAG_MINOR) \
+               -b $(product) -p $(product) \
+               -r $(region) -r $(region) -l $(language) \
+               -I $@ -o $@.new
+       mv $@.new $@
+endef
+
+define Build/buffalo-dhp-image
+       $(STAGING_DIR_HOST)/bin/mkdhpimg $@ $@.new
+       mv $@.new $@
 endef
 
 define Build/netgear-chk
@@ -16,7 +49,7 @@ define Build/netgear-chk
                -o $@.new \
                -k $@ \
                -b $(NETGEAR_BOARD_ID) \
-               -r $(NETGEAR_REGION)
+               $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
        mv $@.new $@
 endef
 
@@ -29,6 +62,18 @@ define Build/netgear-dni
        mv $@.new $@
 endef
 
+# append a fake/empty rootfs uImage header, to fool the bootloaders
+# rootfs integrity check
+define Build/append-uImage-fakeroot-hdr
+       rm -f $@.fakeroot
+       $(STAGING_DIR_HOST)/bin/mkimage \
+               -A $(LINUX_KARCH) -O linux -T filesystem -C none \
+               -n '$(call toupper,$(LINUX_KARCH)) LEDE fakeroot' \
+               -s \
+               $@.fakeroot
+       cat $@.fakeroot >> $@
+endef
+
 define Build/tplink-safeloader
        -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
                -B $(TPLINK_BOARD_NAME) \