ar71xx: image: drop unused mtdlayouts from legacy.mk
[openwrt/openwrt.git] / include / image-commands.mk
index 49e438954a804f487652603d7e6682716b533c2b..c1d89825a3bc383ac9200af2093867ba05f0960c 100644 (file)
@@ -8,7 +8,7 @@ define Build/uImage
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
-       @mv $@.new $@
+       mv $@.new $@
 endef
 
 define Build/buffalo-enc
@@ -49,7 +49,7 @@ define Build/netgear-chk
                -o $@.new \
                -k $@ \
                -b $(NETGEAR_BOARD_ID) \
-               -r $(NETGEAR_REGION)
+               $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
        mv $@.new $@
 endef