build: introduce STAGING_DIR_IMAGE
[openwrt/openwrt.git] / include / image-commands.mk
index 04fa853fbbd99936c547d5eb0862137cba22809d..e0f2918a3876af03ecbb09b5d6ffc6596d5b24fd 100644 (file)
@@ -110,6 +110,10 @@ define Build/append-rootfs
        dd if=$(IMAGE_ROOTFS) >> $@
 endef
 
+define Build/append-file
+       cat "$(1)" >> "$@"
+endef
+
 define Build/append-ubi
        sh $(TOPDIR)/scripts/ubinize-image.sh \
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \