wireguard-tools: bump to 1.0.20200513
[openwrt/openwrt.git] / include / image-commands.mk
index 3d10b18bc82fc8b7faecd527c86ef988100db52c..e7db7128b4cac775ca424c96bebf1405db6937b4 100644 (file)
@@ -3,6 +3,10 @@
 IMAGE_KERNEL = $(word 1,$^)
 IMAGE_ROOTFS = $(word 2,$^)
 
+define rootfs_align
+$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
+endef
+
 define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
@@ -265,12 +269,19 @@ define Build/xor-image
 endef
 
 define Build/check-size
-       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $@)" ] || { \
+       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(if $(1),$(1),$(IMAGE_SIZE)))))) -ge "$$(stat -c%s $@)" ] || { \
                echo "WARNING: Image file $@ is too big" >&2; \
                rm -f $@; \
        }
 endef
 
+define Build/check-kernel-size
+       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $(IMAGE_KERNEL))" ] || { \
+               echo "WARNING: Kernel for $@ is too big > $(1)" >&2; \
+               rm -f $@; \
+       }
+endef
+
 define Build/combined-image
        -sh $(TOPDIR)/scripts/combined-image.sh \
                "$(IMAGE_KERNEL)" \
@@ -335,6 +346,24 @@ define Build/tplink-v1-header
        @mv $@.new $@
 endef
 
+# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
+# -a align the rootfs start on an <align> bytes boundary
+# -j add jffs2 end-of-filesystem markers
+# -s strip padding from end of the image
+# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
+define Build/tplink-v1-image
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) \
+               -N "$(VERSION_DIST)" -V $(REVISION) -m $(TPLINK_HEADER_VERSION) \
+               -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new -j -X 0x40000 \
+               -a $(call rootfs_align,$(FILESYSTEM)) \
+               $(wordlist 2,$(words $(1)),$(1)) \
+               $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
+endef
+
 define Build/tplink-v2-header
        $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
                -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
@@ -373,14 +402,11 @@ metadata_json = \
 
 define Build/append-metadata
        $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
-       [ -z "$(SIGNED_IMAGES)" \
-               -o ! -s "$(BUILD_KEY)" \
-               -o ! -s "$(BUILD_KEY).ucert" \
-               -o ! -s "$@" ] || { \
-                       cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
-                       usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
-                       ucert -A -c "$@.ucert" -x "$@.sig" ;\
-                       fwtool -S "$@.ucert" "$@" ;\
+       [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
+               cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
+               usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
+               ucert -A -c "$@.ucert" -x "$@.sig" ;\
+               fwtool -S "$@.ucert" "$@" ;\
        }
 endef
 
@@ -388,3 +414,10 @@ define Build/kernel2minor
        kernel2minor -k $@ -r $@.new $(1)
        mv $@.new $@
 endef
+
+# Convert a raw image into a $1 type image.
+# E.g. | qemu-image vdi
+define Build/qemu-image
+       qemu-img convert -f raw -O $1 $@ $@.new
+       @mv $@.new $@
+endef