Revert "kernel: prevent addition of scm marker to localversion"
[openwrt/openwrt.git] / include / image.mk
index ad9535d0189c4618c5c1d85d3bbd643508180a3e..3f5b4544e9e31e423cafe804d01727f011eab258 100644 (file)
@@ -277,7 +277,7 @@ endif
 
 ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
   define Image/Build/cpiogz
-       ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+       ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
   endef
 endif