kernel: bump 4.4 to 4.4.108
[openwrt/openwrt.git] / include / image.mk
index 2d7b1ef99860e22551f40729cb9463ddf801058b..605cb066729324f9dd5d165857544d6a6757d2ab 100644 (file)
@@ -136,7 +136,7 @@ endef
 
 define Image/BuildKernel/MkuImage
        mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
-               -n '$(call toupper,$(ARCH)) LEDE Linux-$(LINUX_VERSION)' -d $(4) $(5)
+               -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
 endef
 
 define Image/BuildKernel/MkFIT
@@ -437,17 +437,22 @@ endef
 
 ifndef IB
 define Device/Build/dtb
+  ifndef BUILD_DTS_$(1)
+  BUILD_DTS_$(1) := 1
   $(KDIR)/image-$(1).dtb: FORCE
-       $(call Image/BuildDTB,$(strip $(2))/$(1).dts,$$@)
+       $(call Image/BuildDTB,$(strip $(2))/$(strip $(3)).dts,$$@)
 
   image_prepare: $(KDIR)/image-$(1).dtb
+  endif
+
 endef
 endif
 
 define Device/Build/kernel
   $$(eval $$(foreach dts,$$(DEVICE_DTS), \
-       $$(call Device/Build/dtb,$$(dts), \
-               $$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)) \
+       $$(call Device/Build/dtb,$$(notdir $$(dts)), \
+               $$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)), \
+               $$(dts) \
        ) \
   ))