brcm63xx: move gzip build command to include/image.mk
[openwrt/openwrt.git] / include / image.mk
index 56c60d608743ab0d9c8216c321c533463207e25c..73fc805bb589da9c9b9a270f3a12dc7524e193dd 100644 (file)
@@ -323,6 +323,11 @@ define Build/lzma
        @mv $@.new $@
 endef
 
+define Build/gzip
+       gzip -9n -c $@ $(1) > $@.new
+       @mv $@.new $@
+endef
+
 define Build/kernel-bin
        rm -f $@
        cp $^ $@