Update 2.6.38 to 2.6.38.2
[openwrt/openwrt.git] / include / image.mk
index d7d981ba1cd2303dae0f28d96130e397e7156d47..c72ec81806d6ef38b17eedafc8f1218a9fad748e 100644 (file)
@@ -19,10 +19,8 @@ IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
 
 ifneq ($(CONFIG_BIG_ENDIAN),)
   JFFS2OPTS     :=  --pad --big-endian --squash -v
-  SQUASHFS_OPTS :=  -be
 else
   JFFS2OPTS     :=  --pad --little-endian --squash -v
-  SQUASHFS_OPTS :=  -le
 endif
 
 ifeq ($(CONFIG_JFFS2_RTIME),y)
@@ -44,17 +42,6 @@ ifneq ($(CONFIG_JFFS2_LZMA),y)
   JFFS2OPTS += -x lzma
 endif
 
-ifneq ($(CONFIG_LINUX_2_6_25),)
-  USE_SQUASHFS3 := y
-endif
-
-ifneq ($(USE_SQUASHFS3),)
-  MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs-lzma
-else
-  MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs4
-  SQUASHFS_OPTS  := -comp lzma -processors 1
-endif
-
 JFFS2_BLOCKSIZE ?= 64k 128k
 
 define add_jffs2_mark
@@ -99,7 +86,7 @@ else
   ifneq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),)
     define Image/mkfs/squashfs
                @mkdir -p $(TARGET_DIR)/overlay
-               $(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
+               $(STAGING_DIR_HOST)/bin/mksquashfs4 $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned -comp lzma -processors 1
                $(call Image/Build,squashfs)
     endef
   endif
@@ -124,7 +111,8 @@ endif
 
 ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
   define Image/mkfs/targz
-               $(TAR) -zcf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+               # Preserve permissions (-p) when building as non-root user
+               $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
   endef
 endif
 
@@ -150,9 +138,10 @@ endif
 
 
 define Image/mkfs/prepare/default
-       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod 0644
-       - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod 0755
-       - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod 0755
+       # Use symbolic permissions to avoid clobbering SUID/SGID/sticky bits
+       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
+       - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
+       - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
        chmod 0777 $(TARGET_DIR)/tmp
 endef