change HOST_STAMP_PREPARED for toolchain builds to make sure that added/removed patch...
[openwrt/openwrt.git] / include / image.mk
index 686c5a551e623f8d7a95d292cf387ec99177e07d..d8cf93fa2cc9852c8cb5edc4791aae502f942eff 100644 (file)
@@ -23,13 +23,13 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
-ifneq ($(CONFIG_LINUX_2_6_29)$(CONFIG_LINUX_2_6_30),)
+ifneq ($(CONFIG_LINUX_2_6_30),)
 USE_SQUASHFS4 := y
 endif
 
 ifneq ($(USE_SQUASHFS4),)
 MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs4
-SQUASHFS_OPTS  := -lzma
+SQUASHFS_OPTS  := -lzma -processors 1
 else
 MKSQUASHFS_CMD := $(STAGING_DIR_HOST)/bin/mksquashfs-lzma
 endif
@@ -92,7 +92,7 @@ endif
 define Image/Checksum
        ( cd ${BIN_DIR} ; \
                $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
-               md5sum > md5sums \
+               md5sum --binary > md5sums \
        )
 endef