fix the issue of httpd no longer working when its root directory is replaced
[openwrt/openwrt.git] / include / kernel-build.mk
index c06ca39403be9e631f6139a3cf40c8f13c5accca..6aec7c7270b8b060e3b52306ae0a915ffd2f6903 100644 (file)
@@ -13,7 +13,7 @@ include $(INCLUDE_DIR)/prereq.mk
 
 LINUX_CONFIG ?= ./config/default
 
--include $(GENERIC_PLATFORM_DIR)/config-template
+-include $(TOPDIR)/target/linux/generic-$(KERNEL)/config-template
 -include $(LINUX_CONFIG)
 
 ifneq ($(CONFIG_ATM),)
@@ -221,10 +221,10 @@ define Profile
        echo "Target-Profile: $(1)"; \
        echo "Target-Profile-Name: $(NAME)"; \
        echo "Target-Profile-Packages: $(PACKAGES)"; \
-       echo "Target-Profile-Description:"; \
        if [ -f ./config/profile-$(1) ]; then \
                echo "Target-Profile-Kconfig: yes"; \
        fi; \
+       echo "Target-Profile-Description:"; \
        getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;