build: add kernel modules to package provides info (along with shared libs)
[openwrt/openwrt.git] / include / kernel-defaults.mk
index 607c8211b8a941aab0fa1d8bb583f9b9540fe8a5..c6f02e65140d5f61f02b9aed217f36775f3b8d1b 100644 (file)
@@ -144,7 +144,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 define Kernel/CompileImage/Initramfs
        $(call Kernel/Configure/Initramfs)
        $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),,rm -f $(TARGET_DIR)/init)
-       rm -rf $(KERNEL_BUILD_DIR)/usr/initramfs_data.cpio*
+       rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
        +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
        #")
        #")