iproute2: support eBFP/XDP object file loading, simplify linking libelf
[openwrt/openwrt.git] / include / kernel-version.mk
index c707950ebdad780dd845664799d9f1f8c2be3b77..82e7f150aab6eda914c29a9ee54f009a5a3d6f33 100644 (file)
@@ -2,13 +2,15 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.14 = .67
-LINUX_VERSION-3.18 = .121
-LINUX_VERSION-4.9 = .125
+LINUX_VERSION-3.18 = .136
+LINUX_VERSION-4.9 = .162
+LINUX_VERSION-4.14 = .105
+LINUX_VERSION-4.19 = .25
 
-LINUX_KERNEL_HASH-4.14.67 = 3f4b056dc27233a78f7a4a35ed6fdcfd0a9680ec40b611a898bb6c8b905070ba
-LINUX_KERNEL_HASH-3.18.121 = 7a8a996433e4af1abd2903f91c390295745d90dd178607b3af82f2df5f95c9b0
-LINUX_KERNEL_HASH-4.9.125 = a764deef61bebfac1d07b2ed6890f93a12a9ab6d3fc3c53e3d850ed4681111cb
+LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
+LINUX_KERNEL_HASH-4.9.162 = b946f44edcc4e1b1ccf51ce17dd8f494556555b31b0663bbaabfad99100dacd5
+LINUX_KERNEL_HASH-4.14.105 = 398bdb98b4e4d0ad0e60f4fa530f3f8451ef8dafdf512b7754aa29953263f6e9
+LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))