ar71xx: enable myloader partition parser on 2.6.30 and 2.6.31
[openwrt/openwrt.git] / include / kernel-version.mk
index b6d495097b9676e0ac9e9fc9f6d29d7d46b21e95..f019897bebf44ab0b642b7b16fe5e205aa7ecd4d 100644 (file)
@@ -1,32 +1,32 @@
 # Use the default kernel version if the Makefile doesn't override it
 
 ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.2
+  LINUX_VERSION?=2.4.37.5
 else
   LINUX_VERSION?=2.6.21.7
 endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.2)
-  LINUX_KERNEL_MD5SUM:=8a390c782991a2bfe7d4f2fc93dab059
+ifeq ($(LINUX_VERSION),2.4.37.5)
+  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
 endif
 ifeq ($(LINUX_VERSION),2.6.21.7)
   LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
 endif
-ifeq ($(LINUX_VERSION),2.6.23.17)
-  LINUX_KERNEL_MD5SUM:=a0300a393ac91ce9c64bf31522b45e2e
-endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
 endif
-ifeq ($(LINUX_VERSION),2.6.27.26)
-  LINUX_KERNEL_MD5SUM:=6c246d71fa4698fb0dee0ed092f0282b
+ifeq ($(LINUX_VERSION),2.6.27.34)
+  LINUX_KERNEL_MD5SUM:=4036300a95c62d6969de674901b26145
 endif
 ifeq ($(LINUX_VERSION),2.6.28.10)
   LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
 endif
-ifeq ($(LINUX_VERSION),2.6.30.1)
-  LINUX_KERNEL_MD5SUM:=7da2e2e31f1c00f2673d2dc50de76b33
+ifeq ($(LINUX_VERSION),2.6.30.8)
+  LINUX_KERNEL_MD5SUM:=76b8397bfb477788b26c834f71e27df6
+endif
+ifeq ($(LINUX_VERSION),2.6.31.1)
+  LINUX_KERNEL_MD5SUM:=8077cd7f7c1cdeb6aef3872441ae5294
 endif
 
 # disable the md5sum check for unknown kernel versions