fix the issue of httpd no longer working when its root directory is replaced
[openwrt/openwrt.git] / include / kernel.mk
index 1f34f00ca4888bd6b6def9c45e643fd89c7ab019..4cf0e7a72d4a8cb48eb45a77d6b59ab4f3dcbde3 100644 (file)
@@ -99,7 +99,7 @@ define KernelPackage
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
-               $(CP) $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
+               $(CP) -L $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
                $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
                $(call KernelPackage/$(1)/install,$$(1))
       endef