always include kernel config for kernel packages
[openwrt/openwrt.git] / include / kernel.mk
index df859a42b033ae5191870d7ecc527e90afeb2066..5b27d2f459c894033d548e062ee9b6ecb10e1ac0 100644 (file)
@@ -51,6 +51,9 @@ endif
 GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
 GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
 
+ifeq ($(DUMP),)
+  -include $(LINUX_DIR)/.config
+endif
 
 define KernelPackage/Defaults
   FILES:=