build system: introduce a new feature called build variants. it allows building a...
[openwrt/openwrt.git] / include / package-defaults.mk
index 3cba736f0f101d282b4033d1056ebe97f4836e11..017a86d1e8d0d4309d10602093be10aa90b16d1e 100644 (file)
@@ -23,7 +23,11 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
-  PKGARCH:=$(ARCH)
+  ifneq ($(CONFIG_TARGET_adm5120),y)
+    PKGARCH:=$(BOARD)
+  else
+    PKGARCH:=$(BOARD)_$(ARCH)
+  endif
   PRIORITY:=optional
   DEFAULT:=
   MENU:=
@@ -33,6 +37,7 @@ define Package/Default
   KCONFIG:=
   BUILDONLY:=
   URL:=
+  VARIANT:=
 endef
 
 Build/Patch:=$(Build/Patch/Default)