build system: introduce a new feature called build variants. it allows building a...
[openwrt/openwrt.git] / include / package-defaults.mk
index e7b66b7f8fdffa2e0d3a60586bcb0cf554031574..017a86d1e8d0d4309d10602093be10aa90b16d1e 100644 (file)
@@ -23,7 +23,11 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
-  PKGARCH:=$(ARCH)
+  ifneq ($(CONFIG_TARGET_adm5120),y)
+    PKGARCH:=$(BOARD)
+  else
+    PKGARCH:=$(BOARD)_$(ARCH)
+  endif
   PRIORITY:=optional
   DEFAULT:=
   MENU:=
@@ -33,6 +37,7 @@ define Package/Default
   KCONFIG:=
   BUILDONLY:=
   URL:=
+  VARIANT:=
 endef
 
 Build/Patch:=$(Build/Patch/Default)
@@ -61,7 +66,8 @@ CONFIGURE_ARGS = \
                --mandir=$(CONFIGURE_PREFIX)/man \
                --infodir=$(CONFIGURE_PREFIX)/info \
                $(DISABLE_NLS) \
-               $(DISABLE_LARGEFILE)
+               $(DISABLE_LARGEFILE) \
+               $(DISABLE_IPV6)
 
 CONFIGURE_VARS = \
                $(TARGET_CONFIGURE_OPTS) \
@@ -84,8 +90,7 @@ define Build/Configure/Default
                $(2) \
                $(CONFIGURE_CMD) \
                $(CONFIGURE_ARGS) \
-               $(1) \
-               $(DISABLE_IPV6); \
+               $(1); \
        fi; \
        )
 endef