include: remove file before overwritting it with replace_script
[openwrt/openwrt.git] / include / package-defaults.mk
index a0f859c6e3f0d8680c6a00e4c0569f4a13bd385c..051cde5020a545cd23f95a662885eafe5c1d1fd2 100644 (file)
@@ -32,6 +32,7 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
+  ABI_VERSION:=
   ifneq ($(PKG_FLAGS),)
     PKGFLAGS:=$(PKG_FLAGS)
   else
@@ -42,7 +43,6 @@ define Package/Default
   else
     PKGARCH:=$(BOARD)
   endif
-  PRIORITY:=optional
   DEFAULT:=
   MENU:=
   SUBMENU:=
@@ -53,6 +53,7 @@ define Package/Default
   HIDDEN:=
   URL:=
   VARIANT:=
+  USERID:=
 endef
 
 Build/Patch:=$(Build/Patch/Default)
@@ -64,6 +65,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
 endif
 
 EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
+DISABLE_NLS:=--disable-nls
 
 CONFIGURE_PREFIX:=/usr
 CONFIGURE_ARGS = \
@@ -96,7 +98,9 @@ CONFIGURE_VARS = \
 CONFIGURE_PATH = .
 CONFIGURE_CMD = ./configure
 
-replace_script=$(FIND) $(1) -name $(2) | $(XARGS) chmod u+w; $(FIND) $(1) -name $(2) | $(XARGS) -n1 cp $(SCRIPT_DIR)/$(2);
+replace_script=$(FIND) $(1) -name $(2) | $(XARGS) chmod u+w; \
+              $(FIND) $(1) -name $(2) | $(XARGS) -n1 cp --remove-destination \
+              $(SCRIPT_DIR)/$(2);
 
 define Build/Configure/Default
        (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/$(strip $(3)); \