fix some netfilter extensions on 2.6.25
[openwrt/openwrt.git] / include / package-ipkg.mk
index f75c0a23f3d2019b745e27bc205abb00140c3853..16378a0f0e0143b4c191dd3727b46904dc3d0a8f 100644 (file)
@@ -23,7 +23,7 @@ define BuildIPKGVariable
 endef
 
 ifeq ($(DUMP),)
-  define BuildIPKG
+  define BuildTarget/ipkg
     IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
     IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
@@ -92,9 +92,6 @@ ifeq ($(DUMP),)
     $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
        -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
-
-    $$(eval $$(call Build/DefaultTargets,$(1)))
-
   endef
 
   $(STAGING_DIR)/etc/ipkg.conf: