add $(STAGING_DIR) as argument to the InstallDev template and update packages accordi...
[openwrt/openwrt.git] / include / package.mk
index 9090455658c3f9b979972168c2ad7be531bb7324..2b93972f24360cc29fb9acd5257883cac5301eed 100644 (file)
@@ -64,7 +64,7 @@ define Build/DefaultTargets
 
   $(STAMP_BUILT): $(STAMP_CONFIGURED)
        $(Build/Compile)
-       $(Build/InstallDev)
+       $(call Build/InstallDev,$(STAGING_DIR))
        touch $$@
 
   ifdef Build/InstallDev
@@ -142,7 +142,7 @@ configure: $(STAMP_CONFIGURED)
 compile:
 install:
 clean: FORCE
-       $(Build/UninstallDev)
+       $(call Build/UninstallDev,$(STAGING_DIR))
        $(Build/Clean)
        @rm -f $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
        @rm -rf $(PKG_BUILD_DIR)