build: make the touch .autoremove call non-fatal
[openwrt/openwrt.git] / include / package.mk
index 01c0333b06934c8bcf81d3ac1e5dfe7a425eb34b..91871f06fbebf24245df3467757175cd1ed6aa51 100644 (file)
@@ -216,7 +216,7 @@ define Build/CoreTargets
 
   ifneq ($(CONFIG_AUTOREMOVE),)
     compile:
-               touch $(PKG_BUILD_DIR)/.autoremove
+               -touch $(PKG_BUILD_DIR)/.autoremove 2>/dev/null >/dev/null
                $(FIND) $(PKG_BUILD_DIR) -mindepth 1 -maxdepth 1 -not '(' -type f -and -name '.*' -and -size 0 ')' -and -not -name '.pkgdir' | \
                        $(XARGS) rm -rf
   endif