also strip the .notes section of the kernel
[openwrt/openwrt.git] / include / package.mk
index 489ed9b5273a03624c9451ea638efbf960d4989b..9bffcd1563982de4e623e22bcf8b1f077e00665d 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 all: $(if $(DUMP),dumpinfo,compile)
 
@@ -63,12 +62,22 @@ define sep
 
 endef
 
+define Build/Exports/Default
+  $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR)/usr/share/aclocal $$(STAGING_DIR)/usr/share/aclocal-* $$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*),-I $$(p))
+  $(1) : export STAGING_PREFIX=$$(STAGING_DIR)/usr
+  $(1) : export PATH=$$(TARGET_PATH_PKG)
+  $(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
+  $(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR)/usr/lib/pkgconfig
+  $(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR)/usr/lib/pkgconfig
+endef
+Build/Exports=$(Build/Exports/Default)
+
 define Build/DefaultTargets
   $(if $(QUILT),$(Build/Quilt))
   $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
   $(call Build/Autoclean)
 
-  $(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG) CONFIG_SITE=$$(CONFIG_SITE)
+  $(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG)
   $(STAMP_PREPARED):
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
@@ -77,14 +86,14 @@ define Build/DefaultTargets
        $(foreach hook,$(Hooks/Prepare/Post),$(call $(hook))$(sep))
        touch $$@
 
-  $(STAMP_CONFIGURED) : export PATH=$$(TARGET_PATH_PKG) CONFIG_SITE=$$(CONFIG_SITE)
-  $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(HOST_STAMP_INSTALLED)
+  $(call Build/Exports,$(STAMP_CONFIGURED))
+  $(STAMP_CONFIGURED): $(STAMP_PREPARED)
        $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
        $(Build/Configure)
        $(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))
        touch $$@
 
-  $(STAMP_BUILT) : export PATH=$$(TARGET_PATH_PKG) CONFIG_SITE=$$(CONFIG_SITE)
+  $(call Build/Exports,$(STAMP_BUILT))
   $(STAMP_BUILT): $(STAMP_CONFIGURED)
        $(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
        $(Build/Compile)
@@ -93,7 +102,7 @@ define Build/DefaultTargets
        $(foreach hook,$(Hooks/Install/Post),$(call $(hook))$(sep))
        touch $$@
 
-  $(STAMP_INSTALLED) : export PATH=$$(TARGET_PATH_PKG) CONFIG_SITE=$$(CONFIG_SITE)
+  $(STAMP_INSTALLED) : export PATH=$$(TARGET_PATH_PKG)
   $(STAMP_INSTALLED): $(STAMP_BUILT)
        $(SUBMAKE) -j1 clean-staging
        rm -rf $(TMP_DIR)/stage-$(PKG_NAME)
@@ -154,7 +163,7 @@ endif
       ), $(BuildTarget/$(target)) \
     ) \
   )
-  $(if $(DUMP),,$(call Build/DefaultTargets,$(1)))
+  $(if $(PKG_HOST_ONLY)$(DUMP),,$(call Build/DefaultTargets,$(1)))
 endef
 
 define pkg_install_files