ixp4xx: Split into two subtargets, one normal and one for boards which boot directly...
[openwrt/openwrt.git] / include / prereq-build.mk
index 9b77a1baf70b32828aaeb6f0ace064b08fc031fc..11ee111ced333dcc6286e9df3089c66a9ad8cb96 100644 (file)
@@ -20,11 +20,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -119,14 +115,6 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
-define Require/git
-       which git-clone
-endef
-
-$(eval $(call Require,git, \
-       Please install git. \
-))
-
 $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))