image: add a build step for building and appending an ubinized rootfs
[openwrt/openwrt.git] / include / prereq-build.mk
index 926a06f8ba4130f5dcafc6bc0166368bff04dc6c..211201af3da1e0aaf85a2b3701f78c3bd0d6f499 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -31,7 +31,8 @@ $(eval $(call SetupHostCommand,gcc, \
        gcc49 --version | grep gcc, \
        gcc48 --version | grep gcc, \
        gcc47 --version | grep gcc, \
-       gcc46 --version | grep gcc))
+       gcc46 --version | grep gcc, \
+       gcc --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-gcc, \
        Please reinstall the GNU C Compiler - it appears to be broken, \
@@ -45,7 +46,8 @@ $(eval $(call SetupHostCommand,g++, \
        g++49 --version | grep g++, \
        g++48 --version | grep g++, \
        g++47 --version | grep g++, \
-       g++46 --version | grep g++))
+       g++46 --version | grep g++, \
+       g++ --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-g++, \
        Please reinstall the GNU C++ Compiler - it appears to be broken, \