mxs: fix automatic status led detection
[openwrt/openwrt.git] / include / prereq-build.mk
index cb23f8564716bf6586c078d5ae4bfa15f6c47bb8..5a743225f65978063d023b5ff3f2d969f476efd3 100644 (file)
@@ -168,8 +168,17 @@ $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
 
+define Require/libssl
+       echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
+               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
+endef
+
+$(eval $(call Require,libssl, \
+       Please install the openssl library (with development headers) \
+))
+
 $(eval $(call RequireCommand,openssl, \
-       Please install openssl. \
+       Please install openssl. \
 ))
 
 define Require/gnu-find