kernel: Update kernel 4.4 to 4.4.0
[openwrt/openwrt.git] / include / prereq-build.mk
index 6f491375c69657eda6d3cf9a32c3e381bbfec6ea..77fa991b04f2c23534b0e58819b0f49fa71f8cbc 100644 (file)
@@ -74,7 +74,7 @@ $(eval $(call TestHostCommand,zlib, \
 $(eval $(call TestHostCommand,libssl, \
        Please install the openssl library (with development headers), \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
 $(eval $(call TestHostCommand,libssl, \
        Please install the openssl library (with development headers), \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
-               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+               gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
 
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
 
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \