include: add umask prereq check
[openwrt/openwrt.git] / include / prereq-build.mk
index 0e145c939b03295dd8ea02768ba89fb000750e97..c3b88db6271631e6fb5a8f720825fcb547dd7d67 100644 (file)
@@ -24,6 +24,10 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
+$(eval $(call TestHostCommand,proper-umask, \
+       Please build with umask 022 - other values produce broken packages, \
+       umask | grep -xF 0022))
+
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc), \
        $(CC) --version | grep gcc, \
@@ -71,10 +75,13 @@ $(eval $(call TestHostCommand,zlib, \
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
                gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
 
+# Xcode deprecated openssl, MacPorts doesn't work nicely for other packages
+ifneq ($(HOST_OS),Darwin)
 $(eval $(call TestHostCommand,libssl, \
        Please install the openssl library (with development headers), \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
                gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
+endif
 
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
@@ -151,17 +158,16 @@ $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
        python2 -V 2>&1 | grep Python, \
        python -V 2>&1 | grep Python))
 
-$(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
-       svn --version | grep Subversion))
-
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))
 
+ifneq ($(HOST_OS),Darwin)
 $(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
        openssl version | grep '\(OpenSSL\|LibreSSL\)'))
+endif
 
 
 # Install ldconfig stub