toolchain: Test for supported versions of GCC
[openwrt/openwrt.git] / include / prereq-build.mk
index 496fc04f1b207402029182d8494d70e61c131e62..c6f99a20718bf9e4708c97b8b76c2c813b7eedfe 100644 (file)
@@ -7,8 +7,6 @@
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
-include $(INCLUDE_DIR)/host.mk
-include $(INCLUDE_DIR)/host-build.mk
 
 SHELL:=sh
 PKG_NAME:=Build dependency
@@ -29,32 +27,36 @@ $(eval $(call TestHostCommand,proper-umask, \
        umask | grep -xE 00[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc), \
-       $(CC) --version | grep gcc, \
-       gcc --version | grep gcc, \
-       gcc49 --version | grep gcc, \
+       Please install the GNU C Compiler (gcc) 4.8 or later \
+       $(CC) -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
+       gcc -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
        gcc48 --version | grep gcc, \
-       gcc47 --version | grep gcc, \
-       gcc46 --version | grep gcc, \
+       gcc49 --version | grep gcc, \
+       gcc5 --version | grep gcc, \
+       gcc6 --version | grep gcc, \
+       gcc7 --version | grep gcc, \
        gcc --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       Please reinstall the GNU C Compiler - it appears to be broken, \
+       \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++), \
-       $(CXX) --version | grep g++, \
-       g++ --version | grep g++, \
-       g++49 --version | grep g++, \
+       Please install the GNU C++ Compiler (g++) 4.8 or later \
+       $(CXX) -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
+       g++ -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
        g++48 --version | grep g++, \
-       g++47 --version | grep g++, \
-       g++46 --version | grep g++, \
+       g++49 --version | grep g++, \
+       g++5 --version | grep g++, \
+       g++6 --version | grep g++, \
+       g++7 --version | grep g++, \
        g++ --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       Please reinstall the GNU C++ Compiler - it appears to be broken, \
+       \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
@@ -123,14 +125,9 @@ $(eval $(call SetupHostCommand,getopt, \
        getopt -o t --long test -- --test | grep '^ *--test *--'))
 
 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
-       gnustat -c%s $(TMP_DIR)/.host.mk, \
-       gstat -c%s $(TMP_DIR)/.host.mk, \
-       stat -c%s $(TMP_DIR)/.host.mk))
-
-$(eval $(call SetupHostCommand,md5sum,, \
-       gmd5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       $(SCRIPT_DIR)/md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e))
+       gnustat -c%s $(TOPDIR)/Makefile, \
+       gstat -c%s $(TOPDIR)/Makefile, \
+       stat -c%s $(TOPDIR)/Makefile))
 
 $(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
        unzip 2>&1 | grep zipfile, \