use the default kernel target on powerpc
[openwrt/openwrt.git] / include / prereq-build.mk
index 11ee111ced333dcc6286e9df3089c66a9ad8cb96..d6d2d73a63c39549936e19f5e2e4c2920f2fbd55 100644 (file)
@@ -103,6 +103,10 @@ $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
+$(eval $(call RequireCommand,python, \
+       Please install python. \
+))
+
 $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
@@ -123,3 +127,18 @@ $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))
+
+define Require/getopt-extended
+       getopt --long - - >/dev/null
+endef
+
+$(eval $(call Require,getopt-extended, \
+       Please install an extended getopt version that supports --long \
+))