kernel: bump 4.14 to 4.14.105
[openwrt/openwrt.git] / include / prereq-build.mk
index 029249f69cb0e835c1b4a4a0408b0b85a87d823f..f7da916f648c5c67f73938308fe2df26177204bb 100644 (file)
@@ -24,7 +24,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
 
 $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
-       umask | grep -xE 00[012][012]))
+       umask | grep -xE 0?0[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc) 4.8 or later, \
@@ -138,11 +138,6 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
-$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time' that supports -f, \
-       gtime --version 2>&1 | grep GNU, \
-       time --version 2>&1 | grep GNU, \
-       busybox time 2>&1 | grep -- '-f FMT'))
-
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))