fix spontaneous rebuilds caused by make package/<name>/update with quilt
[openwrt/openwrt.git] / include / subdir.mk
index 40a06ed9e13ab33533bb0af35d86463f99d9ff43..68afcc48a25444a0226debbc61db6bab4453aec3 100644 (file)
@@ -34,10 +34,10 @@ define subdir
   $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name> <target>
+# Parameters: <subdir> <name> <target> <depends>
 define stampfile
   $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
-  $$($(1)/stamp-$(3)): $(TMP_DIR)/.build
+  $$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
        @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
                $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
        @mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))