fix PACKAGES:= for target profiles in target.mk
[openwrt/openwrt.git] / include / target.mk
index 17a41f7c492817b739f8f8c6dc40a51069bb8f7f..1718a869c14780853bc61c69f9d66cf4769d87b7 100644 (file)
@@ -5,6 +5,14 @@
 # See /LICENSE for more information.
 #
 
+
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
+
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)
@@ -12,6 +20,6 @@ $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@
 else
 $(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
-       $(SCRIPT_DIR)/gen_target_mk.pl < $(TMP_DIR)/.targetinfo > $@
+       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
 endif