fix PACKAGES:= for target profiles in target.mk
[openwrt/openwrt.git] / include / target.mk
index 6a136a1bee4dbd16d7eee3a4b84f45b7c6075dd2..1718a869c14780853bc61c69f9d66cf4769d87b7 100644 (file)
@@ -5,21 +5,14 @@
 # See /LICENSE for more information.
 #
 
+
 define AddProfile
-  $(eval $(call Profile/Default))
-  $(eval $(call Profile/$(1)))
-  ifneq ($(ID),)
-    PROFILE:=$(ID)
-       $(ID)_NAME:=$(NAME)
-       $(ID)_PACKAGES:=$(PACKAGES)
-    ifneq ($(KCONFIG),)
-      PROFILE_LIST += \
-               echo '$(ID):'; [ -z '$(NAME)' ] || echo '       $(NAME)'; echo '        Packages: $(PACKAGES)';
-    endif
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
   endif
 endef
 
-
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)