fix PACKAGES:= for target profiles in target.mk
[openwrt/openwrt.git] / include / target.mk
index bd3ceb955b7f00d0f76eb6d6305a2d9be5bd5e68..1718a869c14780853bc61c69f9d66cf4769d87b7 100644 (file)
@@ -5,6 +5,14 @@
 # See /LICENSE for more information.
 #
 
+
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
+
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)