image.mk: add CMDLINE to DEVICE_VARS
[openwrt/openwrt.git] / include / target.mk
index 6a0ec97cbf0eee5173551d3750aa3ba3ec9b51bc..3fc2bd7508389e17d2699aa03e115ddd658c010d 100644 (file)
@@ -91,7 +91,7 @@ else
   endef
 endif
 
-PROFILE:=$(call qstrip,$(CONFIG_TARGET_PROFILE))
+PROFILE?=$(call qstrip,$(CONFIG_TARGET_PROFILE))
 
 ifeq ($(TARGET_BUILD),1)
   ifneq ($(DUMP),)
@@ -208,6 +208,7 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_8540:=-mcpu=8540
     CPU_CFLAGS_405:=-mcpu=405
     CPU_CFLAGS_440:=-mcpu=440
+    CPU_CFLAGS_464fp:=-mcpu=464fp
   endif
   ifeq ($(ARCH),sparc)
     CPU_TYPE = sparc