download.mk: fix packed checkout mirroring support
[openwrt/openwrt.git] / include / target.mk
index f1292987f22d3f289ba7cfa37d5650f943425c93..54ee463477e19b772507f63a2ae81182a0677d16 100644 (file)
@@ -12,7 +12,7 @@ __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools
+DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg netifd fstools uclient-fetch
 # For nas targets
 DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
 # For router targets
@@ -263,6 +263,7 @@ ifeq ($(DUMP),1)
   endif
   ifeq ($(ARCH),arc)
     CPU_TYPE ?= arc700
+    CPU_CFLAGS += -matomic
     CPU_CFLAGS_arc700 = -marc700
   endif
   DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))