image.mk: fix evaluation order for image profile check
[openwrt/openwrt.git] / include / target.mk
index 08e0a62af64eaab81e839be56156dc07149a04b0..92edaec96b0e8b40a4cdcc3bee02912c30232ff9 100644 (file)
@@ -67,19 +67,12 @@ ifndef Profile
 define Profile
   $(eval $(call ProfileDefault))
   $(eval $(call Profile/$(1)))
-  dumpinfo : $(call shexport,Profile/$(1)/Config)
   dumpinfo : $(call shexport,Profile/$(1)/Description)
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
        $(if $(PRIORITY), echo "Target-Profile-Priority: $(PRIORITY)"; ) \
        echo "Target-Profile-Name: $(NAME)"; \
        echo "Target-Profile-Packages: $(PACKAGES) $(call extra_packages,$(DEFAULT_PACKAGES) $(PACKAGES))"; \
-       if [ -f ./config/profile-$(1) ]; then \
-               echo "Target-Profile-Kconfig: yes"; \
-       fi; \
-       echo "Target-Profile-Config: "; \
-       echo "$$$$$$$$$(call shvar,Profile/$(1)/Config)"; \
-       echo "@@"; \
        echo "Target-Profile-Description:"; \
        echo "$$$$$$$$$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
@@ -274,7 +267,7 @@ endif
 
 CUR_SUBTARGET:=$(SUBTARGET)
 ifeq ($(SUBTARGETS),)
-  CUR_SUBTARGET ?= default
+  CUR_SUBTARGET := default
 endif
 
 define BuildTargets/DumpCurrent