expunge find GNUism
[openwrt/openwrt.git] / include / target.mk
index 9156789c88df4fd95a5615914a5f426f7bafae01..ef3f1dbbe07d9314754f25eedb12558b0654489f 100644 (file)
@@ -5,13 +5,29 @@
 # See /LICENSE for more information.
 #
 
+ifneq ($(__target_inc),1)
+__target_inc=1
+
+# default device type
+DEVICE_TYPE?=router
+
+# Default packages - the really basic set
+DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd
+# For router targets
+DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe iptables kmod-ipt-nathelper bridge
+
+# Additional packages for Linux 2.6
+ifneq ($(KERNEL),2.4)
+  DEFAULT_PACKAGES += udevtrigger hotplug2
+endif
+
+# Add device specific packages
+DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
+
 ifneq ($(DUMP),)
   all: dumpinfo
 endif
 
-ifneq ($(__target_inc),1)
-__target_inc=1
-
 target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 ifeq ($(DUMP),)
   PLATFORM_DIR:=$(TOPDIR)/target/linux/$(BOARD)
@@ -39,6 +55,7 @@ define Profile/Default
   PACKAGES:=
 endef
 
+ifndef Profile
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
@@ -62,6 +79,7 @@ define Profile
     PROFILE=$(1)
   endif
 endef
+endif
 
 ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
   define IncludeProfiles
@@ -117,6 +135,9 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
       FEATURES += pcmcia
     endif
+    ifneq ($(CONFIG_VGA_CONSOLE)$(CONFIG_FB),)
+      FEATURES += display
+    endif
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))