add STAGING_DIR_HOST to PKG_CONFIG_PATH
[openwrt/openwrt.git] / include / toplevel.mk
index ba5cb33759b828f361266449832631aa4de6f738..4e194bf50a08980f57df57b417a5f42b79a8b99e 100644 (file)
@@ -7,21 +7,22 @@
 #
 
 RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
 SHELL:=/usr/bin/env bash
-OPENWRTVERSION:=$(RELEASE)
 PREP_MK= OPENWRT_BUILD= QUIET=0
+
 include $(TOPDIR)/include/verbose.mk
-ifneq ($(VERSION),)
-  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+
+ifeq ($(SDK),1)
+  include $(TOPDIR)/include/version.mk
 else
-  REV:=$(if $(wildcard .svn/entries),$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' ))
-  ifneq ($(REV),)
-    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-  endif
+  REVISION:=$(shell $(TOPDIR)/scripts/getver.sh)
 endif
+
+OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
+export RELEASE
+export REVISION
 export OPENWRTVERSION
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
@@ -97,7 +98,7 @@ download: .config FORCE
        $(MAKE) -j1 package/download
        $(MAKE) -j1 target/download
 
-clean dirclean:
+clean dirclean: .config
        @$(MAKE) $@ 
 
 prereq:: .config