change HOST_STAMP_PREPARED for toolchain builds to make sure that added/removed patch...
[openwrt/openwrt.git] / include / toplevel.mk
index dd8fcd6f3029a183d6d18afa0f81324b21f7ec4b..78a03d877f9173f754d6ee3cdb41a0e44800c88d 100644 (file)
@@ -26,6 +26,9 @@ export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 
+# prevent perforce from messing with the patch utility
+unexport P4PORT P4USER P4CONFIG P4CLIENT
+
 # make sure that a predefined CFLAGS variable does not disturb packages
 export CFLAGS=