package/lldpd: Remove extraneous select
[openwrt/openwrt.git] / include / toplevel.mk
index 2e13f623dcab8ae5a38e13148ce1481080a4c1d9..c8f342b48fc4e0476312d993060172fa7e52de57 100644 (file)
@@ -6,7 +6,7 @@
 # See /LICENSE for more information.
 #
 
-RELEASE:=Chaos Calmer
+RELEASE:=Designated Driver
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
@@ -20,12 +20,8 @@ else
 endif
 
 HOSTCC ?= $(CC)
-OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
 export RELEASE
 export REVISION
-export OPENWRTVERSION
-export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
-export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
 export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))
 
@@ -161,11 +157,13 @@ download: .config FORCE
        @+$(SUBMAKE) target/download
 
 clean dirclean: .config
-       @+$(SUBMAKE) -r $@ 
+       @+$(SUBMAKE) -r $@
 
 prereq:: prepare-tmpinfo .config
        @+$(NO_TRACE_MAKE) -r -s $@
 
+WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
+
 ifeq ($(SDK),1)
 
 %::
@@ -184,10 +182,27 @@ else
                        printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
                fi \
        )
-       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@ $(if $(WARN_PARALLEL_ERROR), || { \
+               printf "$(_R)Build failed - please re-run with -j1 to see the real error message$(_N)\n" >&2; \
+               false; \
+       } )
 
 endif
 
+# update all feeds, re-create index files, install symlinks
+package/symlinks:
+       ./scripts/feeds update -a
+       ./scripts/feeds install -a
+
+# re-create index files, install symlinks
+package/symlinks-install:
+       ./scripts/feeds update -i
+       ./scripts/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+       ./scripts/feeds uninstall -a
+
 help:
        cat README
 
@@ -198,7 +213,7 @@ docs/clean: FORCE
        @$(_SINGLE)$(SUBMAKE) -C docs clean
 
 distclean:
-       rm -rf tmp build_dir staging_dir dl .config* feeds package/feeds package/openwrt-packages bin
+       rm -rf bin build_dir .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
        @$(_SINGLE)$(SUBMAKE) -C scripts/config clean
 
 ifeq ($(findstring v,$(DEBUG)),)