libcxx[abi]: remove
[openwrt/openwrt.git] / include / u-boot.mk
index 0c2865332631f03f7c7920701ce4e073af1e3c89..ec9fb15b6ce27d51d592331713c6774c87759feb 100644 (file)
@@ -3,7 +3,8 @@ PKG_NAME ?= u-boot
 ifndef PKG_SOURCE_PROTO
 PKG_SOURCE = $(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL = \
-       http://sources.lede-project.org \
+       https://mirror.cyberbits.eu/u-boot \
+       https://ftp.denx.de/pub/u-boot \
        ftp://ftp.denx.de/pub/u-boot
 endif
 
@@ -40,6 +41,11 @@ endef
 
 TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
 
+UBOOT_MAKE_FLAGS = \
+       HOSTCC="$(HOSTCC)" \
+       HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS) -std=gnu11" \
+       HOSTLDFLAGS="$(HOST_LDFLAGS)"
+
 define Build/U-Boot/Target
   $(eval $(call U-Boot/Init,$(1)))
   $(eval $(call U-Boot/Default,$(1)))