odhcp6c: handle NoAddrsAvail IA-status
[openwrt/openwrt.git] / include / version.mk
index af25be02f755ac5c83444b85c18368294cf095c4..2bf709e56e69fc663af24ed5e939ca8611fe525c 100644 (file)
@@ -5,6 +5,9 @@
 # See /LICENSE for more information.
 #
 
+# Substituted by SDK, do not remove
+# REVISION:=x
+
 PKG_CONFIG_DEPENDS += \
        CONFIG_VERSION_NUMBER \
        CONFIG_VERSION_NICK \
@@ -37,4 +40,4 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
        -e 's,%d,\L$(subst $(space),_,$(VERSION_DIST)),g' \
        -e 's,%R,$(REVISION),g' \
        -e 's,%T,$(BOARD),g' \
-       -e 's,%S,$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET)),g' \
+       -e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \