add some ioctl stuff from wrt54gs.2.06 source
[openwrt/openwrt.git] / openwrt / Makefile
index ef60ff198812031cf5b80f4d7895aa61bddabfc1..e966188187e9d57eb1f3cc1886157ea0fffa4b24 100644 (file)
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+ifneq ($(DEVELOPER),)
+CONFIG_CONFIG_IN = Config.in.devel
+else
 CONFIG_CONFIG_IN = Config.in
+endif
 CONFIG_DEFCONFIG = .defconfig
 CONFIG = package/config
 
@@ -41,6 +45,8 @@ include $(TOPDIR)/rules.mk
 
 all: world
 
+.NOTPARALLEL:
+
 ##############################################################
 #
 # Build the toolchain
@@ -116,7 +122,7 @@ dirclean: clean
        rm -rf $(BUILD_DIR)
 
 distclean: clean
-       rm -rf $(STAMP_DIR) $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR)
+       rm -rf $(STAMP_DIR) $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) $(STAGING_DIR)
        rm -f .config* .tmpconfig.h
 
 sourceball: distclean