handle postinit for initramfs
[openwrt/openwrt.git] / openwrt / include / verbose.mk
index 7d9b3979bffcb171ff025375d4c1324a6ebca5ab..36002aee990b029c8eb6907e421ef4a4b47a5853 100644 (file)
@@ -6,13 +6,21 @@
 #
 # $Id:$
 
-export NO_TRACE_MAKE:=$(MAKE) V=99
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=0
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
+endif
+
+ifneq ($(shell tty -s <&3 || echo x),x)
+  _Y:="\\33[33m"# yellow
+  _N:="\\33[m"#        normal
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)
@@ -21,7 +29,7 @@ ifneq ($(KBUILD_VERBOSE),99)
     trace: FORCE
        @[ -f "$(MAKECMDGOALS)" ] || { \
                [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+               echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
        }
   else
     export QUIET:=1