only check prerequisites of actually selected packages
[openwrt/openwrt.git] / openwrt / package / Makefile
index d2b7468a394a5dd01286f5db5ef17aa77f7d39a6..e94c181ba023877de9b72d59ab426dd1a125e054 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/.config
 include $(TOPDIR)/.pkgdeps
 include $(TOPDIR)/host.mk
 
-PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(package-prereq))
+PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(prereq-y) $(prereq-m))
 DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
 COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
 INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))