let ipkg fail when a package file to be installed is not found
[openwrt/openwrt.git] / openwrt / package / avahi / Makefile
index a6b4a626a7002dba4032f436f1aa973a00436531..b77a9c35ee3607adae48be2dcf677766f467e946 100644 (file)
@@ -3,11 +3,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.1
+PKG_VERSION:=0.6.10
 PKG_RELEASE:=1
-PKG_MD5SUM:=1ccbbc46d2aedf0c864b94c58ea220e6
+PKG_MD5SUM:=cfb9e05c138dff4c430a35eee6229e8a
 
-PKG_SOURCE_URL:=http://www.freedesktop.org/~lennart/
+PKG_SOURCE_URL:=http://avahi.org/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
@@ -23,12 +23,13 @@ $(eval $(call PKG_template,LIBAVAHI,libavahi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS) -DNDEBUG" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_func_realloc_0_nonnull=yes \
+               ac_cv_func_memcmp_working=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
@@ -54,18 +55,31 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-rpath \
                        --with-gnu-ld \
                        --disable-glib \
+                       --disable-qt3 \
+                       --disable-qt4 \
                        --disable-gtk \
                        --disable-dbus \
                        --enable-expat \
                        --enable-libdaemon \
                        --disable-python \
+                       --disable-pygtk \
+                       --disable-python-dbus \
+                       --disable-mono \
+                       --disable-monodoc \
                        --disable-doxygen-doc \
                        --disable-doxygen-dot \
+                       --disable-doxygen-man \
+                       --disable-doxygen-rtf \
+                       --disable-doxygen-xml \
+                       --disable-doxygen-chm \
+                       --disable-doxygen-chi \
                        --disable-doxygen-html \
                        --disable-doxygen-ps \
                        --disable-doxygen-pdf \
                        --disable-xmltoman \
-                       --with-distro=openwrt \
+                       --with-distro=none \
+                       --with-avahi-user=nobody \
+                       --with-avahi-group=nogroup \
        );
        touch $@
 
@@ -79,39 +93,43 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_AVAHI_DAEMON):
        install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/avahi
-       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/avahi-daemon.conf $(IDIR_AVAHI_DAEMON)/etc/avahi/
-       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/services $(IDIR_AVAHI_DAEMON)/etc/avahi/
+       install -m0644 ./files/avahi-daemon.conf $(IDIR_AVAHI_DAEMON)/etc/avahi/
+       install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/avahi/services
+       install -m0644 ./files/service-http $(IDIR_AVAHI_DAEMON)/etc/avahi/services/http.service
+       install -m0644 ./files/service-ssh $(IDIR_AVAHI_DAEMON)/etc/avahi/services/ssh.service
+       install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/init.d
+       install -m0755 ./files/avahi-daemon.init $(IDIR_AVAHI_DAEMON)/etc/init.d/avahi-daemon
        install -d -m0755 $(IDIR_AVAHI_DAEMON)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(IDIR_AVAHI_DAEMON)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(IDIR_AVAHI_DAEMON)/usr/sbin/
        $(RSTRIP) $(IDIR_AVAHI_DAEMON)
        $(IPKG_BUILD) $(IDIR_AVAHI_DAEMON) $(PACKAGE_DIR)
 
 $(IPKG_AVAHI_DNSCONFD):
        install -d -m0755 $(IDIR_AVAHI_DNSCONFD)/etc/avahi
-       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/avahi-dnsconfd.action $(IDIR_AVAHI_DNSCONFD)/etc/avahi/
+       $(CP) $(PKG_INSTALL_DIR)/etc/avahi/avahi-dnsconfd.action $(IDIR_AVAHI_DNSCONFD)/etc/avahi/
        install -d -m0755 $(IDIR_AVAHI_DNSCONFD)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(IDIR_AVAHI_DNSCONFD)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(IDIR_AVAHI_DNSCONFD)/usr/sbin/
        $(RSTRIP) $(IDIR_AVAHI_DNSCONFD)
        $(IPKG_BUILD) $(IDIR_AVAHI_DNSCONFD) $(PACKAGE_DIR)
 
 $(IPKG_LIBAVAHI):
        install -d -m0755 $(IDIR_LIBAVAHI)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.so.* $(IDIR_LIBAVAHI)/usr/lib/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.so.* $(IDIR_LIBAVAHI)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.so.* $(IDIR_LIBAVAHI)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.so.* $(IDIR_LIBAVAHI)/usr/lib/
        $(RSTRIP) $(IDIR_LIBAVAHI)
        $(IPKG_BUILD) $(IDIR_LIBAVAHI) $(PACKAGE_DIR)
 
 $(STAGING_DIR)/usr/lib/avahi.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
-       cp -fpR $(PKG_INSTALL_DIR)/usr/include/avahi-common $(STAGING_DIR)/usr/include/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/include/avahi-core $(STAGING_DIR)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-common $(STAGING_DIR)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/avahi-core $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.a $(STAGING_DIR)/usr/lib/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.so* $(STAGING_DIR)/usr/lib/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.a $(STAGING_DIR)/usr/lib/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.so* $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.a $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-common.so* $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.a $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavahi-core.so* $(STAGING_DIR)/usr/lib/
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/avahi-core.pc $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
        $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc
        touch $@
@@ -128,8 +146,8 @@ uninstall-dev:
                $(STAGING_DIR)/usr/lib/libavahi-core.so* \
                $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc \
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
 
 mostlyclean:
        -$(MAKE) -C $(PKG_BUILD_DIR) clean