add support for Package/<pkgname>/description - old format still supported, but depre...
[openwrt/openwrt.git] / openwrt / package / busybox / Makefile
index c87701ad1e5a24f94801c8b1d1f82571539e5e64..05174a32bda0dd0b8bb2cfeb065de2bcabf6ed9d 100644 (file)
@@ -26,15 +26,19 @@ define Package/busybox
   CATEGORY:=Base system
   DEFAULT:=y
   TITLE:=Core utilities for embedded Linux
-  DESCRIPTION:=\
-       The Swiss Army Knife of embedded Linux. \\\
-       It slices, it dices, it makes Julian Fries.
   URL:=http://busybox.net/
   MENU:=1
-  CONFIG:=\\\
-       menu "Configuration" \\\
-               depends on PACKAGE_busybox \\\
-               source "$(SOURCE)/config/Config.in" \\\
+endef
+
+define Package/busybox/description
+The Swiss Army Knife of embedded Linux.
+       It slices, it dices, it makes Julian Fries.
+endef
+
+define Package/busybox/config
+       menu "Configuration"
+               depends on PACKAGE_busybox
+               source "$(SOURCE)/config/Config.in"
        endmenu
 endef