standardize Makefile, change section from base to net and category to "base system"
[openwrt/openwrt.git] / openwrt / package / dnsmasq / Makefile
index a05ec0e22cbe8e1e7525076d1ede0c30979e2a08..3dc22a3a02060d916bcb7a08079732eb7509cd76 100644 (file)
@@ -1,27 +1,33 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.27
+PKG_VERSION:=2.33
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=489198ec87101087043adc98bbe062dc
+PKG_MD5SUM:=45696461b6e6bc929273b1191ca50447
 PKG_CAT:=zcat
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/dnsmasq
-SECTION:=base
-CATEGORY:=Network
-DEFAULT:=y
-TITLE:=A lightweight DNS and DHCP server
-DESCRIPTION:=A lightweight DNS and DHCP server.  It is intended to provide \\\
-coupled DNS and DHCP service to a LAN.
-URL:=http://www.thekelleys.org.uk/dnsmasq/
+  SECTION:=net
+  CATEGORY:=Base system
+  DEFAULT:=y
+  TITLE:=A lightweight DNS and DHCP server
+  DESCRIPTION:=\
+       It is intended to provide coupled DNS and DHCP service to a LAN.
+  URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
 define Package/dnsmasq/conffiles
@@ -30,18 +36,19 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
                all
 endef
 
 define Package/dnsmasq/install
+       install -m0755 -d $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        install -m0755 -d $(1)/etc
        install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        install -m0755 -d $(1)/etc/init.d
        install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,dnsmasq))